Snappy

Helpdesk Support

Official Supportmonk Company Blog!

Dowgrade PHP from PHP 5.4 to PHP 5.3 on Plesk

April 22, 2014 , 11:02 am


At first need to edit yum.conf

vi /etc/yum.conf
add
exclude=php*5.4*

Now downgrade using

yum downgrade $(rpm -qa –queryformat=”%{name} \n” |grep ^php)

If php-fpm is installed,  you may end up with an error like

——————————————————————————————————————————————————

                                        Error: Package: psa-phpfpm-configurator-1.0.0-cos6.build115130618.12.x86_64 (@PSA_11_5_30-dist)
Requires: php-fpm >= 5.3.9
Removing: php-fpm-5.4.21-27.el6.art.x86_64 (@atomic)
php-fpm = 5.4.21-27.el6.art
Downgraded By: php-fpm-5.3.3-23.el6_4.x86_64 (updates)
php-fpm = 5.3.3-23.el6_4
Available: php-fpm-5.3.3-22.el6.x86_64 (base)
php-fpm = 5.3.3-22.el6
You could try using –skip-broken to work around the problem
You could try running: rpm -Va –nofiles –nodigest
———————————————————————————————————————————————————
In this case remove php-fpm from plesk. I  suggest you to remove php-fpm and nginx together.  Once its done run the command again
     yum downgrade $(rpm -qa –queryformat=”%{name} \n” |grep ^php)

 

Envelope Icon

Get Updates Your Email!

Subscribe to Supportmonk and receive blog posts to your email!

Subscribe Via Email

SupportMonk on Facebook


Outsourced Customer Support