Snappy

Helpdesk Support

Official Supportmonk Company Blog!

OpenVZ – RHEL/CentOS/Scientific 6.5 Container Networking Bug

December 22, 2013 , 7:44 pm


opnvzIn this article, I would like to discuss an issue that I have faced recently. We all knew that Centos  has released  latest version 6.5 with more features. You can get the complete details at http://wiki.centos.org/Manuals/ReleaseNotes/CentOS6.5   Openvz installed in this version is having some network issues which is a bug with this version and can rectified. I got this issue when I upgraded vzkernel to  2.6.18-348.16.1.el5.028stab108.1  from stab101.1

There wont be any  active network interfaces. You can verify it using ifconfig

==============

[[email protected] ~]# ifconfig
[[email protected] ~]#
==============

I have tried to restart the network and got the error given below.

=====================================
[[email protected] log]# service network restart
Shutting down loopback interface:                          [  OK  ]
FATAL: Module ipv6 not found.
Bringing up loopback interface:  RTNETLINK answers: Operation not supported
Failed to bring up lo.
                                                           [FAILED]
Bringing up interface venet0:  RTNETLINK answers: Operation not supported
Failed to bring up venet0.
                                                           [FAILED]
FATAL: Module ipv6 not found.

==============================

Openvz doesnt have an official fix yet. Best way to fix this issue would be downgrading iproute package.

Download iproute to your hardware node and move it to corresponding vps

============================================

[email protected] [~]# wget http://blog.supportmonk.com/download/iproute-2.6.32-23.el6.x86_64.rpm

[email protected] [~]# mv iproute-2.6.32-23.el6.x86_64.rpm  /vz/private/VID/root

[email protected] [~]# rpm -Uvh –force iproute-2.6.32-23.el6.x86_64.rpm

if a latest version is already installed, remove using

[email protected] [~]#rpm -e iproute-2.6.32-23.el6_5.x86_64.rpm -nodeps

and try installing using

[email protected] [~]# rpm -Uvh –force iproute-2.6.32-23.el6.x86_64.rpm

[email protected] [~]# service network restart

VID should be replaced with your container ID.

============================================

Outsourced Customer Support